const regex = /for [^(]+\(([^)]+)\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('for [^(]+\\(([^)]+)\\)', 'g')
const str = `Nmap scan report for ns525464.ip-8-26-94.net (8.26.94.30)
Nmap scan report for ns525465.ip-8-26-94.net (8.26.94.31)`;
const subst = `for \1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);