$re = '/for [^(]+\(([^)]+)\)/';
$str = 'Nmap scan report for ns525464.ip-8-26-94.net (8.26.94.30)
Nmap scan report for ns525465.ip-8-26-94.net (8.26.94.31)';
$subst = "for \1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;