#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\[embed type="(?:facebook|twitter|pinterest)"\](.*)\[\/embed\]"
Local $sString = "[embed type="pinterest"]https://www.facebook.com/Techzoom.TV/posts/1960179340843049[/embed]" & @CRLF & _
"[embed type="Twitter"]https://twitter.com/HelloBdWorld/status/1568289461284524033[/embed]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")