$re = '/\[embed type="(?:facebook|twitter|pinterest)"\](.*)\[\/embed\]/i';
$str = '[embed type="pinterest"]https://www.facebook.com/Techzoom.TV/posts/1960179340843049[/embed]
[embed type="Twitter"]https://twitter.com/HelloBdWorld/status/1568289461284524033[/embed]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);