using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[embed type=""(?:facebook|twitter|pinterest)""\](.*)\[\/embed\]";
string input = @"[embed type=""pinterest""]https://www.facebook.com/Techzoom.TV/posts/1960179340843049[/embed]
[embed type=""Twitter""]https://twitter.com/HelloBdWorld/status/1568289461284524033[/embed]";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}