import Foundation
let pattern = #"\[embed type="(?:facebook|twitter|pinterest)"\](.*)\[\/embed\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
[embed type="pinterest"]https://www.facebook.com/Techzoom.TV/posts/1960179340843049[/embed]
[embed type="Twitter"]https://twitter.com/HelloBdWorld/status/1568289461284524033[/embed]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)