#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<name>.{39})(?<port>.{15})(?<info>.{26})(?<protocol>.+)"
Local $sString = "Windows remote mgmt RPC 135 @FirewallAPI TCP" & @CRLF & _
"Corenet-12345 421 TCP" & @CRLF & _
"Port 75 and 443 UDP"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")