package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<name>.{39})(?<port>.{15})(?<info>.{26})(?<protocol>.+)`)
var str = `Windows remote mgmt RPC 135 @FirewallAPI TCP
Corenet-12345 421 TCP
Port 75 and 443 UDP`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}