re = /(?<name>.{39})(?<port>.{15})(?<info>.{26})(?<protocol>.+)/
str = 'Windows remote mgmt RPC 135 @FirewallAPI TCP
Corenet-12345 421 TCP
Port 75 and 443 UDP'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end