$re = '/(?<name>.{39})(?<port>.{15})(?<info>.{26})(?<protocol>.+)/';
$str = 'Windows remote mgmt RPC 135 @FirewallAPI TCP
Corenet-12345 421 TCP
Port 75 and 443 UDP';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);