import Foundation
let pattern = #"(?<name>.{39})(?<port>.{15})(?<info>.{26})(?<protocol>.+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Windows remote mgmt RPC 135 @FirewallAPI TCP
Corenet-12345 421 TCP
Port 75 and 443 UDP
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)