import re
regex = re.compile(r"(?<name>.{39})(?<port>.{15})(?<info>.{26})(?<protocol>.+)")
test_str = ("Windows remote mgmt RPC 135 @FirewallAPI TCP\n"
"Corenet-12345 421 TCP\n"
"Port 75 and 443 UDP")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")