// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?<name>.{39})(?<port>.{15})(?<info>.{26})(?<protocol>.+)").unwrap();
let string = "Windows remote mgmt RPC 135 @FirewallAPI TCP
Corenet-12345 421 TCP
Port 75 and 443 UDP";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}