# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(tags:)/$1\n - m\/diary/gm;t' <<< "---
anykey: somevalue
tags:
- sometag
- sometag2
anyotheryamlkey: somevalue
anyotheryamlkey2:
- somevalue1
---
Main body text.
More text."