import re
regex = re.compile(r"(tags:)", flags=re.MULTILINE)
test_str = ("---\n"
"anykey: somevalue\n"
"tags:\n"
" - sometag\n"
" - sometag2\n"
"anyotheryamlkey: somevalue\n"
"anyotheryamlkey2: \n"
" - somevalue1\n"
"---\n\n"
"Main body text.\n"
"More text.")
subst = "$1\\n - m/diary"
result = regex.sub(subst, test_str)
if result:
print(result)