re = /(tags:)/m
str = '---
anykey: somevalue
tags:
- sometag
- sometag2
anyotheryamlkey: somevalue
anyotheryamlkey2:
- somevalue1
---
Main body text.
More text.'
subst = '$1\\n - m/diary'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result