$re = '/(tags:)/m';
$str = '---
anykey: somevalue
tags:
- sometag
- sometag2
anyotheryamlkey: somevalue
anyotheryamlkey2:
- somevalue1
---
Main body text.
More text.';
$subst = "$1\n - m/diary";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;