using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(tags:)";
string substitution = @"$1\n - m/diary";
string input = @"---
anykey: somevalue
tags:
- sometag
- sometag2
anyotheryamlkey: somevalue
anyotheryamlkey2:
- somevalue1
---
Main body text.
More text.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}