import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(tags:)";
final String string = "---\n"
+ "anykey: somevalue\n"
+ "tags:\n"
+ " - sometag\n"
+ " - sometag2\n"
+ "anyotheryamlkey: somevalue\n"
+ "anyotheryamlkey2: \n"
+ " - somevalue1\n"
+ "---\n\n"
+ "Main body text.\n"
+ "More text.";
final String subst = "$1\\n - m/diary";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}