# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s+[A-Z]$//gm;t' <<< "Smith, Jake K
Howard, Rob
Smith-Howard, Emily R
McDonald, Jim T
McCormick, Erica"