#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s+[A-Z]$"
Local $sString = "Smith, Jake K" & @CRLF & _
"Howard, Rob" & @CRLF & _
"Smith-Howard, Emily R" & @CRLF & _
"McDonald, Jim T" & @CRLF & _
"McCormick, Erica"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)