re = /\s+[A-Z]$/m
str = 'Smith, Jake K
Howard, Rob
Smith-Howard, Emily R
McDonald, Jim T
McCormick, Erica'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result