// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s+[A-Z]$").unwrap();
let string = "Smith, Jake K
Howard, Rob
Smith-Howard, Emily R
McDonald, Jim T
McCormick, Erica";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}