const regex = new RegExp('\\s+[A-Z]$', 'gm')
const str = `Smith, Jake K
Howard, Rob
Smith-Howard, Emily R
McDonald, Jim T
McCormick, Erica`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);