$re = '/\s+[A-Z]$/m';
$str = 'Smith, Jake K
Howard, Rob
Smith-Howard, Emily R
McDonald, Jim T
McCormick, Erica';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;