using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+[A-Z]$";
string substitution = @"";
string input = @"Smith, Jake K
Howard, Rob
Smith-Howard, Emily R
McDonald, Jim T
McCormick, Erica";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}