import Foundation
let pattern = #"\s+[A-Z]$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Smith, Jake K
Howard, Rob
Smith-Howard, Emily R
McDonald, Jim T
McCormick, Erica
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)