package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s+[A-Z]$`)
var str = `Smith, Jake K
Howard, Rob
Smith-Howard, Emily R
McDonald, Jim T
McCormick, Erica`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}