# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^Link[\s]*([a-zA-Z\\/\-]*)[\s]*([a-zA-Z\\/\-]*)$/\2/mg;t' <<< "Link Europe/London Yup
Link America/London Golden
Link Asia/London GB-EFire
Link Croatia/London GB-EFire
"