import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Link[\\s]*([a-zA-Z\\/\\-]*)[\\s]*([a-zA-Z\\/\\-]*)$";
final String string = "Link Europe/London Yup\n"
+ "Link America/London Golden\n"
+ "Link Asia/London GB-EFire\n"
+ "Link Croatia/London GB-EFire\n";
final String subst = "\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}