import re
regex = re.compile(r"^Link[\s]*([a-zA-Z\/\-]*)[\s]*([a-zA-Z\/\-]*)$", flags=re.MULTILINE)
test_str = ("Link Europe/London Yup\n"
"Link America/London Golden\n"
"Link Asia/London GB-EFire\n"
"Link Croatia/London GB-EFire\n")
subst = "\\2"
result = regex.sub(subst, test_str)
if result:
print(result)