const regex = /^Link[\s]*([a-zA-Z\/\-]*)[\s]*([a-zA-Z\/\-]*)$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Link[\\s]*([a-zA-Z\\\/\\-]*)[\\s]*([a-zA-Z\\\/\\-]*)$', 'mg')
const str = `Link Europe/London Yup
Link America/London Golden
Link Asia/London GB-EFire
Link Croatia/London GB-EFire
`;
const subst = `\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);