$re = '/^Link[\s]*([a-zA-Z\/\-]*)[\s]*([a-zA-Z\/\-]*)$/m';
$str = 'Link Europe/London Yup
Link America/London Golden
Link Asia/London GB-EFire
Link Croatia/London GB-EFire
';
$subst = "\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;