#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)@design-prop-value\s(.+?)(\s?\*\/)?$"
Local $sString = "export interface HasTabIndex {" & @CRLF & _
" /**" & @CRLF & _
" * Tabindex of the component." & @CRLF & _
" * @design-prop-value 10" & @CRLF & _
" * @design-prop-value 20" & @CRLF & _
" * */" & @CRLF & _
" tabIndex: number;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" /** Unique id of the element. */" & @CRLF & _
" /** @design-prop-value "UNIQQUE_ID_FOR_ELEMENT"*/" & @CRLF & _
" @Input()" & @CRLF & _
" get id(): string { return this._id; }" & @CRLF & _
" set id(value: string) { this._id = value || this._uid; }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")