re = /@design-prop-value\s(.+?)(\s?\*\/)?$/m
str = 'export interface HasTabIndex {
/**
* Tabindex of the component.
* @design-prop-value 10
* @design-prop-value 20
* */
tabIndex: number;
}
/** Unique id of the element. */
/** @design-prop-value "UNIQQUE_ID_FOR_ELEMENT"*/
@Input()
get id(): string { return this._id; }
set id(value: string) { this._id = value || this._uid; }'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end