import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@design-prop-value\\s(.+?)(\\s?\\*\\/)?$";
final String string = "export interface HasTabIndex {\n"
+ " /**\n"
+ " * Tabindex of the component.\n"
+ " * @design-prop-value 10\n"
+ " * @design-prop-value 20\n"
+ " * */\n"
+ " tabIndex: number;\n"
+ "}\n\n\n\n"
+ " /** Unique id of the element. */\n"
+ " /** @design-prop-value \"UNIQQUE_ID_FOR_ELEMENT\"*/\n"
+ " @Input()\n"
+ " get id(): string { return this._id; }\n"
+ " set id(value: string) { this._id = value || this._uid; }";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}