const regex = /@design-prop-value\s(.+?)(\s?\*\/)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@design-prop-value\\s(.+?)(\\s?\\*\\\/)?$', 'gm')
const str = `export interface HasTabIndex {
/**
* Tabindex of the component.
* @design-prop-value 10
* @design-prop-value 20
* */
tabIndex: number;
}
/** Unique id of the element. */
/** @design-prop-value "UNIQQUE_ID_FOR_ELEMENT"*/
@Input()
get id(): string { return this._id; }
set id(value: string) { this._id = value || this._uid; }`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}