use strict;
my $str = 'export interface HasTabIndex {
/**
* Tabindex of the component.
* @design-prop-value 10
* @design-prop-value 20
* */
tabIndex: number;
}
/** Unique id of the element. */
/** @design-prop-value "UNIQQUE_ID_FOR_ELEMENT"*/
@Input()
get id(): string { return this._id; }
set id(value: string) { this._id = value || this._uid; }';
my $regex = qr/@design-prop-value\s(.+?)(\s?\*\/)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}