// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)@design-prop-value\s(.+?)(\s?\*\/)?$").unwrap();
let string = "export interface HasTabIndex {
/**
* Tabindex of the component.
* @design-prop-value 10
* @design-prop-value 20
* */
tabIndex: number;
}
/** Unique id of the element. */
/** @design-prop-value \"UNIQQUE_ID_FOR_ELEMENT\"*/
@Input()
get id(): string { return this._id; }
set id(value: string) { this._id = value || this._uid; }";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}