# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"@design-prop-value\s(.+?)(\s?\*\/)?$"
test_str = ("export interface HasTabIndex {\n"
" /**\n"
" * Tabindex of the component.\n"
" * @design-prop-value 10\n"
" * @design-prop-value 20\n"
" * */\n"
" tabIndex: number;\n"
"}\n\n\n\n"
" /** Unique id of the element. */\n"
" /** @design-prop-value \"UNIQQUE_ID_FOR_ELEMENT\"*/\n"
" @Input()\n"
" get id(): string { return this._id; }\n"
" set id(value: string) { this._id = value || this._uid; }")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.