package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)@design-prop-value\s(.+?)(\s?\*\/)?$`)
var str = `export interface HasTabIndex {
/**
* Tabindex of the component.
* @design-prop-value 10
* @design-prop-value 20
* */
tabIndex: number;
}
/** Unique id of the element. */
/** @design-prop-value "UNIQQUE_ID_FOR_ELEMENT"*/
@Input()
get id(): string { return this._id; }
set id(value: string) { this._id = value || this._uid; }`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}