import Foundation
let pattern = #"@design-prop-value\s(.+?)(\s?\*\/)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
export interface HasTabIndex {
/**
* Tabindex of the component.
* @design-prop-value 10
* @design-prop-value 20
* */
tabIndex: number;
}
/** Unique id of the element. */
/** @design-prop-value "UNIQQUE_ID_FOR_ELEMENT"*/
@Input()
get id(): string { return this._id; }
set id(value: string) { this._id = value || this._uid; }
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)