#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)1\.1\.1\.(?:19[1-9]|2[0-4]\d|25[0-4])"
Local $sString = "1.1.1.100" & @CRLF & _
"1.1.1.200" & @CRLF & _
"1.1.1.192" & @CRLF & _
"1.1.1.196" & @CRLF & _
"1.1.1.202" & @CRLF & _
"1.1.1.201" & @CRLF & _
"1.1.1.220" & @CRLF & _
"1.1.1.222" & @CRLF & _
"1.1.1.225" & @CRLF & _
"1.1.1.230" & @CRLF & _
"1.1.1.160" & @CRLF & _
"1.1.1.175" & @CRLF & _
"1.1.1.225" & @CRLF & _
"1.1.1.234" & @CRLF & _
"1.1.1.254" & @CRLF & _
"1.1.1.255" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")