use strict;
my $str = '1.1.1.100
1.1.1.200
1.1.1.192
1.1.1.196
1.1.1.202
1.1.1.201
1.1.1.220
1.1.1.222
1.1.1.225
1.1.1.230
1.1.1.160
1.1.1.175
1.1.1.225
1.1.1.234
1.1.1.254
1.1.1.255
';
my $regex = qr/1\.1\.1\.(?:19[1-9]|2[0-4]\d|25[0-4])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}