import re
regex = re.compile(r"1\.1\.1\.(?:19[1-9]|2[0-4]\d|25[0-4])", flags=re.MULTILINE)
test_str = ("1.1.1.100\n"
"1.1.1.200\n"
"1.1.1.192\n"
"1.1.1.196\n"
"1.1.1.202\n"
"1.1.1.201\n"
"1.1.1.220\n"
"1.1.1.222\n"
"1.1.1.225\n"
"1.1.1.230\n"
"1.1.1.160\n"
"1.1.1.175\n"
"1.1.1.225\n"
"1.1.1.234\n"
"1.1.1.254\n"
"1.1.1.255\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")