package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)1\.1\.1\.(?:19[1-9]|2[0-4]\d|25[0-4])`)
var str = `1.1.1.100
1.1.1.200
1.1.1.192
1.1.1.196
1.1.1.202
1.1.1.201
1.1.1.220
1.1.1.222
1.1.1.225
1.1.1.230
1.1.1.160
1.1.1.175
1.1.1.225
1.1.1.234
1.1.1.254
1.1.1.255
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}