import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "1\\.1\\.1\\.(?:19[1-9]|2[0-4]\\d|25[0-4])";
final String string = "1.1.1.100\n"
+ "1.1.1.200\n"
+ "1.1.1.192\n"
+ "1.1.1.196\n"
+ "1.1.1.202\n"
+ "1.1.1.201\n"
+ "1.1.1.220\n"
+ "1.1.1.222\n"
+ "1.1.1.225\n"
+ "1.1.1.230\n"
+ "1.1.1.160\n"
+ "1.1.1.175\n"
+ "1.1.1.225\n"
+ "1.1.1.234\n"
+ "1.1.1.254\n"
+ "1.1.1.255\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}