import Foundation
let pattern = #"1\.1\.1\.(?:19[1-9]|2[0-4]\d|25[0-4])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1.1.1.100
1.1.1.200
1.1.1.192
1.1.1.196
1.1.1.202
1.1.1.201
1.1.1.220
1.1.1.222
1.1.1.225
1.1.1.230
1.1.1.160
1.1.1.175
1.1.1.225
1.1.1.234
1.1.1.254
1.1.1.255
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)