re = /1\.1\.1\.(?:19[1-9]|2[0-4]\d|25[0-4])/m
str = '1.1.1.100
1.1.1.200
1.1.1.192
1.1.1.196
1.1.1.202
1.1.1.201
1.1.1.220
1.1.1.222
1.1.1.225
1.1.1.230
1.1.1.160
1.1.1.175
1.1.1.225
1.1.1.234
1.1.1.254
1.1.1.255
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end