using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"1\.1\.1\.(?:19[1-9]|2[0-4]\d|25[0-4])";
string input = @"1.1.1.100
1.1.1.200
1.1.1.192
1.1.1.196
1.1.1.202
1.1.1.201
1.1.1.220
1.1.1.222
1.1.1.225
1.1.1.230
1.1.1.160
1.1.1.175
1.1.1.225
1.1.1.234
1.1.1.254
1.1.1.255
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}